GTP4o: Strange behavior - trying to run python code instead of answering simple question?

Link to chat.

I’ve seen this kind of behavior many times before; I ask a non-coding question and it turns into an endless loop of julius generating, running and debugging non-working python code. Is there a setting somewhere that I don’t see?

1 Like

Do you know if you have the “search” function on while asking Julius to perform the searches for you? You can turn this on while simultaneously turning off the “coding” section in the “tools” section.

Let me know if this helps at all.

I have seen it do this a few times over the last few days, even with the Search selected. I will try to capture it and share it here if I can recreate it.

Interesting. Does it only happen when you are using the GTP4o model?

I think that is what I noticed, but I will test it. :slight_smile:

1 Like

I’ve seen this error-debugging loop happen with Claude as well, but what I’ve now figured out is that the problem can be solved by choosing “model chat” (thanks Chris!)

So that fixes the problem for me, but I do wish the model would be better at determining when to offer code and when to just reply normally, though.

1 Like

That actually has worked for me too


Is it only happens at GTP4o

@hillarytuitoe, it only happens when you’re using GTP4o? Even if you change it to the search only setting still?

Often you can tell it to explicitly stop doing something. So if it responds with a python script you can put (no code) before and/or after whatever you’re asking, also apparently using a period can help. So try something like this:

(No code) This is my question, blah blah blah. (Do not show me code).

1 Like

Here’s a fresh example of this happening with the new Claude 3.5 Sonnet modek. It tries to answer a simple question with a python script, and then grinds to a halt when the code (obviously) won’t run.

I disabled [code] and [search] but couldn’t enable [model chat] with Claude 3.5.

Hi all!

I just wanted to share that I see it with Claude 3.5 Sonnet when I turn off the Python environment, but it still wants to use it when I prompt it for a PowerShell script.